易语言 注册多个热键方法

  • 内容
  • 评论
  • 相关

20160917082439

首先创建一个“标签”组件,然后参考如下代码。

20160917082624

源码文件下载:注册多个热键.rar

.版本 2
.支持库 shellEx

.程序集 窗口程序集_启动窗口
.程序集变量 热键标识1, 整数型, , , F1
.程序集变量 热键标识2, 整数型, , , F2
.程序集变量 热键标识3, 整数型, , , F3

.子程序 __启动窗口_创建完毕

热键标识1 = 注册热键 (取窗口句柄 (), 标签1.取窗口句柄 (), 0, #F1键) ' 此处“#F1键”也可以替换为键盘代码。
热键标识2 = 注册热键 (取窗口句柄 (), 标签1.取窗口句柄 (), 0, #F2键)
热键标识3 = 注册热键 (取窗口句柄 (), 标签1.取窗口句柄 (), 0, #F3键)

.子程序 _标签1_反馈事件, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型

.如果真 (参数一 = 热键标识1)
信息框 (“F1被按下”, 0, , )
.如果真结束
.如果真 (参数一 = 热键标识2)
信息框 (“F2被按下”, 0, , )
.如果真结束
.如果真 (参数一 = 热键标识3)
信息框 (“F3被按下”, 0, , )
.如果真结束

.子程序 __启动窗口_将被销毁

撤销热键 (取窗口句柄 (), 热键标识1)
撤销热键 (取窗口句柄 (), 热键标识2)
撤销热键 (取窗口句柄 (), 热键标识3)

评论

0条评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注