易语言 窗口淡入淡出效果

  • 内容
  • 评论
  • 相关

20161004115122

使用此方法可实现窗口的淡入淡出效果,不需要添加任何窗口组件(比如时钟等),而是直接用代码实现,代码如下:

源码文件下载:淡入淡出窗口.rar

.版本 2
.支持库 eAPI
.支持库 EThread
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

设置窗口透明度 (取窗口句柄 (), 0)
启动线程 (&进入透明化, , )
可视 = 假

.子程序 进入透明化
.局部变量 透明度, 整数型

.变量循环首 (1, 200, 5, 透明度)
可视 = 真
设置窗口透明度 (取窗口句柄 (), 透明度)
延迟 (10)
.变量循环尾 ()
延迟 (50)

.子程序 退出透明化
.局部变量 透明度, 整数型

.变量循环首 (200, 1, -5, 透明度)
设置窗口透明度 (取窗口句柄 (), 透明度)
延迟 (10)
.变量循环尾 ()
延迟 (50)
可视 = 假
销毁 ()

.子程序 __启动窗口_窗口可否被关闭, 逻辑型

退出透明化 ()

评论

0条评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注